Tag Archives: ISP

Cirrus Communications is bad mmmkay

This is a warning to anyone thinking of using Cirrus Communications as an ISP.

I have contacted the support desk, and accounts, and Jodi Weal (apparently she is the Operations Manager) countless times since the 18/2/2008, about 2 issues I have. I have been told on every occasion that someone will call me back (and the last time, I gave them my work number also), and I still haven’t received one phone call.  I have rang on at least 3 occasions asking for a refund for the 12 months I have already paid up front, but they tell me that their policy doesn’t allow them to do that, without being first given the opportunity to correct the issue.  How much of an opportunity do they need, obviously 1 month is not long enough, especially since they can not seem to work out how to pick up the phone and make a call.

1st issue.  I paid 12 months up front for a 2048/512 (40GB downloads) connection at $1300 on the 18/2/2008.  I was previously on the 512/128 (unlimited).  My problem is, my internet connection is still running at the 512k speed.  And it is now almost a month later.

2nd issue.  My internet for the past 4 months has been stopping after 10 – 24 hours.  In which i have to reboot my router (from the web interface).  I have tried a different router with the same result, and also a direct PC connection with the same result.

Honestly I don’t know how these guys can deliver a service like this.  The customer support I have received over the past few weeks is just plain appalling.  I have sent them a couple of emails fairly similar to this, and letting them know that I am seriously considering reporting them to the Office of Fair Trading, and issuing warnings on the Whirlpool forums to anyone thinking of using Cirrus as an ISP.  And so it has begun, this is my first step, posting it here on my Blog.

They are charging me $130 per month for an internet service which I was previously paying $55 per month for, and also as a bonus I am getting twice daily drop outs, which remains not working until I physically reboot the router.  This is just not on.

So I ask that anyone who is willing, to help me boycott Cirrus until they realise that they cannot treat their customers this way.